Back to Top

EQ7: Error 1642 Installing EQ7 Update

Also applies to: EQStitch

Error 1642 occurs because you have “EQStitch” installed and you are attempting to install the “EQ7” Update.

You cannot update your EQStitch using an EQ7 Update file. Click here to update your EQStitch.

If you do not have EQStitch and still receive a 1642 error, please check to be sure you are updating using the correct files. If you continue to have problems, please contact our support team.