Updated 12/1/2021

EQ8 and BlockBase+ are supported on macOS Monterey, which was released on October 25, 2021.

With EQ8, you may receive the warning message pictured below the first time you open the application. You can click OK and use the software normally.

The warning message just states there may be incompatibility with our software in future macOS releases. We have released an update for EQ8 to remove that message and ensure compatibility with our software and future macOS releases. Click here to get the update to 3.2.0.5 now.

Screen Shot 2021-10-27 at 2.24.19 PM

If you have any questions, please contact our office.